Sie sind nicht angemeldet.

blender export problem

Antworten im Thema: 8 » Der letzte Beitrag (24. Juni 2015, 17:20) ist von Schlemil.

Lieber Besucher, herzlich willkommen bei: Trucksimulator24 - Die freundliche Trucksimulator Community rund um den Euro Truck Simulator 2, Euro Trucksimulator, German Truck Simulator, 18 Wheels of Steel Reihe, Extreme Trucker und den ZModeler.. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Flitzebogen

Gliederzug-Fahrer

  • »Flitzebogen« ist männlich
  • »Flitzebogen« ist der Autor dieses Themas

Beiträge: 136

Wohnort: Plauen

OS: Win 10 - 64 bit

Game: ETS 2 /ATS

GV: 1.30.0.12 / 1.29.1.1

Danksagungen: 2145

  • Nachricht senden

1

Dienstag, 23. Juni 2015, 19:58

blender export problem

Hallo zusammen

habe ein ähnliches Problem wie im bereits geschlossen Beitrag ohne wirkliche Bekanntgabe was jetzt die Ursache bzw. die Lösung war.

Nun zum eigendlichen Problem:

Habe mir im Blender das Interior vom DAF XF Euro 6 importiert, wollte dort einen zusätzlichen Slot platziern und das Interior wieder exportieren. dabei bekomme ich folgende Fehlermeldung:



Um Fehler auszuschliessen, habe ich versucht, das Interior ohne zu bearbeiten zu exportieren und erhalte diese Fehlermeldung auch.

Bitte um eure Hilfe

Allzeit eine Handbreit Teer unterm Reifen und einen Handbreit Luft zwischen Trailer und Brücke

D4LYNCHHD

Gigaline-Fahrer

  • »D4LYNCHHD« ist männlich

Beiträge: 521

Wohnort: Burgenlandkreis

Danksagungen: 14826

  • Nachricht senden

2

Dienstag, 23. Juni 2015, 21:28

Das Problem gibts schon ewig.Einfach vor dem Export alle Materials durchsuchen und unvollständige rauslöschen oder vervollständigen. :thumbup:


Flitzebogen

Gliederzug-Fahrer

  • »Flitzebogen« ist männlich
  • »Flitzebogen« ist der Autor dieses Themas

Beiträge: 136

Wohnort: Plauen

OS: Win 10 - 64 bit

Game: ETS 2 /ATS

GV: 1.30.0.12 / 1.29.1.1

Danksagungen: 2145

  • Nachricht senden

3

Dienstag, 23. Juni 2015, 21:33

Danke für die Info und das Bild dazu.

Hab es mir nochmal angeschaut und die gezeigen Zeilen gefunden und entfernt. Export hat funktioniert 8o

Allzeit eine Handbreit Teer unterm Reifen und einen Handbreit Luft zwischen Trailer und Brücke

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Flitzebogen« (23. Juni 2015, 21:53)


Hendrik89

Gliederzug-Fahrer

  • »Hendrik89« ist männlich

Beiträge: 268

Wohnort: ERZGEBIRGE

Danksagungen: 4388

  • Nachricht senden

4

Dienstag, 23. Juni 2015, 21:55

das muss sooo lauten:

aux[5]: (1.0, 0.0, 0.0)
aux[6]: (0.0, 1.0, 0.0)
aux[7]: (0.0, 0.0, 1.0)

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Flitzebogen

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

5

Dienstag, 23. Juni 2015, 22:26

Ich habe mir mal die exportierte mat angesehen,wo solch ein eintrag im Blender vorangegangen gelöscht wurde.
Hier jetzt die von dem Daf Euro6 Interior.
Da wird ein texture[4] -tobj-Pfad geschrieben aber ohne den zweiten Eintrag texture_name[4] zusatz.
Der bezieht sich auf "flakenoise"

Die gelöschten Aux-einträge haben aber ori werte. ( 4er-Gruppen )

3 Lösungen:
Sinn macht es also die Einträge im Blender zu löschen. ( aux-Nummer merken )
hochscrollen und die automat-Nr. notieren. ( Im Blender 762d32c22fd807418e708cd8435f16ed0c37c8 )
Nach dem Export die ori model.pmd mit nem editor öffnen und den kompletten Pfad zur notierten mat heraussuchen.
In diesem Fall = automat/9e/762d32c22fd807418e708cd8435f16ed0c37c8 und diese ori-werte wieder in deiner exportierten ( 762d32c22fd807418e708cd8435f16ed0c37c8 ) mat kopieren.
So hast dann auch alle original effekte die ao und Ledertextur betreffen.

Oder vorher die ori mat finden und die ori werte in Blender eintragen.
aux[5] : { 35 , 30 , 2.4 , 0 }
aux[6] : { 1 , 1 , 1 , 0.7 }
aux[7] : { 0.86 , 0.392819 , 0.20812 , 1.3 }
Da bleibt aber immernoch der fehlende texture_name{4] ,den du dir aus der ori mat rauskopiren musst.

Oder,nach vorangegangenem löschen der Aux-Einträge in Blender für ein fehlerfreies exportieren,
die ori mat verwenden und in der mat einfach die Pfade anpassen,da sie sich nach dem export geändert haben zur den tobj´s.
Das ist wohl die unkompizierteste Methode,da man bei allen drei Lösungen die ori-mat zur Hand haben muss.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Schlemil« (24. Juni 2015, 15:29)


Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Flitzebogen

Hendrik89

Gliederzug-Fahrer

  • »Hendrik89« ist männlich

Beiträge: 268

Wohnort: ERZGEBIRGE

Danksagungen: 4388

  • Nachricht senden

6

Dienstag, 23. Juni 2015, 22:39

da is das ding...wegen 4 werten in der .mat kommt das problem beim import :dance:

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

7

Dienstag, 23. Juni 2015, 22:43

ja,lassen sich aber in Blender eintragen und exportieren.
Nur halt dieses flakenoise wird noch ohne den zweiten zusatz exportiert.
Weil es dort wo die Auxwerte in Blender unten steht. Iss also irgend ein zusätzlicher shader ( seit game 1.14.xx und ao ) den Blender nicht kennt.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Flitzebogen

Flitzebogen

Gliederzug-Fahrer

  • »Flitzebogen« ist männlich
  • »Flitzebogen« ist der Autor dieses Themas

Beiträge: 136

Wohnort: Plauen

OS: Win 10 - 64 bit

Game: ETS 2 /ATS

GV: 1.30.0.12 / 1.29.1.1

Danksagungen: 2145

  • Nachricht senden

8

Mittwoch, 24. Juni 2015, 17:12

danke euch beiden für die Hilfe.

@Schlemil ich gehe mal davon aus, das "ori mat" bei dir die kurzform für "Original-Mat" steht.
Werde mich in den kommenden Stunden nochmal darüber machen. Gehe mal davon aus, dass mich dieses Problem auch bei anderen Interior-Exporten treffen wird.

Allzeit eine Handbreit Teer unterm Reifen und einen Handbreit Luft zwischen Trailer und Brücke

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

9

Mittwoch, 24. Juni 2015, 17:20

ori = original. jop.

Das problem besteht meines wissens nur bei den neuen Fahrzeugen ( hier jetzt nur der Daf Euro6 ) von SCS,die ein ao mapping und / oder neue Textureffekte mitbringen.
Der MP4 hat da schon wieder anderes Problem,was die dds für das ao mapping angeht. Die wird von Blender nicht richtig gelesen,da es sich um eine 32bit dds handelt.
Ändert man diese ab in dxt1 format,funktioniert die.
Werden die alten Truck von SCS mal überarbeitet,kann es dir dort dann auch passieren.
Die Moddingprogramme sind insoweit noch nicht komplett aktualisiert. Bei Zmodeler gibbet ja ständig updates. Bei Blender siehts da anders aus.
Da wird an neuen Programmen / addons gearbeitet wie die Blender Tools,die das alte SCS ETS2 addon wohl irgendwann komplett ablösen werden.

Sei noch gesagt,dass SCS sich reichlich Mühe mit dem Game macht und deshalb eben ständig Änderungen kommen,die es uns moddern immer wieder erschweren.
Das eine möchte man,dann muss man mit dem anderen leben. ;) Sprich will man Spielverbesserungen von SCS,muss man mit der konsequenz leben und immer wieder anpassen.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Flitzebogen

Social Bookmarks

Counter:

Hits heute: 8 941 | Hits gestern: 9 882 | Hits Tagesrekord: 102 526 | Hits gesamt: 49 014 944 | Hits pro Tag: 20 479,76

Klicks heute: 45 855 | Klicks gestern: 74 580 | Klicks Tagesrekord: 756 082 | Klicks gesamt: 438 417 353 | Klicks pro Tag: 183 182,52 | Gezählt seit: 3. Mai 2011, 07:40

Ungelesene Beiträge Unbeantwortete Themen Themen der letzten 24 Stunden

Euro Truck Simulator,Euro Truck Simulator 2,German Truck Simulator,Forum,Community,Downloads,Support,Euro Trucksimulator,Euro Trucksimulator 2,German Trucksimulator,Trucks,18 Wheels of Steel,Haulin,Convoy,Pttm,Long Haul,Trucksimulator,Trucksimulation,Truck Simulator,Simulation,ATS,Trucksim,Extreme Trucker 2,ETS,ETS2,GTS,UKTS,ET,ET2,18WoS,Tutorial,Tutorials,Tipp,Zmodeler,z3d,Modding,SCS,simulation,support, Zmod,z3d,Sk,Skins,Map,Maps,Mod,Mods,Trucksims,STD,Scania Truck Driving Simulator,Scania,ETS2Mods, Euro Trucksimulator2 Mods