Sie sind nicht angemeldet.

Nach Zmod3 Exportirert nur Rot

Antworten im Thema: 12 » Der letzte Beitrag (22. März 2016, 07:48) ist von apache079.

Lieber Besucher, herzlich willkommen bei: Trucksimulator24 - Die freundliche Trucksimulator Community rund um den Euro Truck Simulator 2, Euro Trucksimulator, German Truck Simulator, 18 Wheels of Steel Reihe, Extreme Trucker und den ZModeler.. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Max1996

Gliederzug-Fahrer

  • »Max1996« ist männlich
  • »Max1996« ist der Autor dieses Themas

Beiträge: 94

Wohnort: Kreis Wesermarsch

OS: Win 10 Pro 64bit

Game: ETS2, ATS

GV: 1.30.X

  • Nachricht senden

1

Dienstag, 2. Februar 2016, 11:45

Nach Zmod3 Exportirert nur Rot

Moin Moin
ich könnte mal eure hilfe gebrauchen undzwar habe ich was gemoddet es mit dem Zmod3 ins spiel gebracht aber es wird in rot abgezeit ich bin so langsam mit mein latein am ende weis jemand eine lösung nur fehler die ich behebe aber die sind immer noch da
Kleiner Log Text

Spoiler Spoiler

00:00:45.829 : <ERROR> [fs] cached read - read request too big (/vehicle/truck/upgrade/bar/black.tobj)
00:00:45.829 : <ERROR> [tobj] Failed reading map name from file '/vehicle/truck/upgrade/bar/black.tobj'.
00:00:45.832 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'
00:00:45.838 : <ERROR> [fs] Failed to open file "/vehicle/truck/upgrade/bar/ÿÿÿÿÿÿÿÿÿÿÿÿflare.vehicle.hella_main" in the read_only mode
00:00:45.838 : <ERROR> [material] Can not open '/vehicle/truck/upgrade/bar/ÿÿÿÿÿÿÿÿÿÿÿÿflare.vehicle.hella_main'
00:00:45.968 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'
00:00:48.743 : Create actor: (99 MB)
00:00:48.761 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'
00:00:48.762 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'
00:00:48.790 : Game init finished. (364 MB)
00:00:55.306 : ui t console:system_02
00:00:55.726 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'
00:00:55.727 : <ERROR> Empty material name in model '/vehicle/truck/upgrade/bar/lightbar.pmd'


Suchtender

Gigaline-Fahrer

  • »Suchtender« ist männlich

Beiträge: 439

Wohnort: Chemnitz

OS: Windows 8 kein 8.1 auf keinen Fall 10

Game: ETS2

Danksagungen: 57

  • Nachricht senden

2

Donnerstag, 4. Februar 2016, 11:37

Hast du das Stand alone gestellt ?

d.h. - rote Modelle = ein Fehler das kein Material gefunden wurde.

Du mußt dafür den Origin Pfad beachten, und natürlich müssen sich deine Materialien + Texturenfiles dann auch in der Schublade befinden.

WIP Thread Trucksimulator24: Thread des Ägypten 2.0 Work in Progress

WICHTIG: Kein Support für Privatmods! Fragen oder PM dazu, werden kommentarlos gelöscht! Ich supporte NUR öffentliche Arbeiten. Beachtet das bitte!

Max1996

Gliederzug-Fahrer

  • »Max1996« ist männlich
  • »Max1996« ist der Autor dieses Themas

Beiträge: 94

Wohnort: Kreis Wesermarsch

OS: Win 10 Pro 64bit

Game: ETS2, ATS

GV: 1.30.X

  • Nachricht senden

3

Donnerstag, 4. Februar 2016, 17:36

ja hatte sich aber erledigt war ein fehler mit dem pfad der mat und tobj's


apache079

Sprinter-Fahrer

Beiträge: 6

  • Nachricht senden

4

Montag, 7. März 2016, 08:10

Moin zusammen,

Ich klinke mich mal ein hier mit meinem Problem. Ich habe versucht eine bestehende Trailermod für den ATS umzubenennen. Ich baue mir eine persönliche Trailer-Cargo wunschlos glücklich Mod mit allem was mir gefällt und meiner Meinung nach passt. Und zur besseren Übersicht der Ordner und Strukturen wollte ich diverse Modelle umbenennen. Gesagt....getan. Das erste Modell soll "dump-bottom" heißen. Also ein bodenentlehrender Grain-Trailer. Also Ordner alle umbenannt, Cargo zugewiesen, Cargo defs umgeschrieben, vehicle defs umgeschrieben, tobjs umgeschrieben (wohlbemerkt mit Notepad++). Nun das Spiel gestartet, in den Trailer Browser, Trailer war da incl Cargo, aber er war rot. Klar...ich hatte vergessen die materials und die pmd umzuschreiben. Also dies schnell gemacht....Spiel gestartet....Absturz. Habe dann herausgefunden dass die tobjs unbedingt per tobj-Editor verändert werden müssen. Habe dies gemacht....Spiel gestartet....kein Absturz....aber der Trailer ist immernoch rot. Habe dann mehrfach nochmals alle defs und alle Pfade in den mats, tobjs und pmd geprüft. Aber da passt alles, keine Rechtschreibfehler, keine Zeichen vergessen. Es wird einfach keine Texturen gefunden, obwohl sie da sind. Deswegen hier meine Frage. Was habe ich übersehen. Oder war der Fehler die Verweise auf die mats im 3D Modell, also in der pmd per Notepad++ zu ändern? Muss ich vielleicht alles in den ZMod importieren und dann etwas ändern? Die Kette der Verweise ist ja folgende: cargo Def - trailer def - trailer chassis def - Modell pmd - mats - tobj - dds. Oder hab ich etwas übersehen? Hat einer nen Vorschlag? ?(

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

5

Montag, 7. März 2016, 08:43

Die Inhalte der pmd müssen mit nem Hexeditor gemacht werden.
Außerdem darf die grösse / pfadlänge nicht verändert werden.
Heißt: du veränderst im pfad in der pmd nur den matnamen.
Der alte mat - Name hat meinetwegen 5 Buchstaben,dann muss der neue auch 5 Buchstaben haben. So bleibt die Menge an Zeichen gleich in der pmd.
alt:
vehicle/trailer_eu/...../beton.mat
neu:
vehicle/trailer_eu/...../beten.mat
Und unbedingt auf die Schreibweise achten.
Schnell hat sich ein Großbuchstabe verirrt,der Pfade ungültig macht.

Ich nutze für die pmd den HexD. Der ist ganz gut.
Und ja,für die tobj unbedingt den tobj editor verwenden.
Andere Texteditoren setzen noch unsichtbare Zeichen ans pfadende.
Das macht der tobj editor auch,aber man kann sie sehen am Ende des Pfades und vor dem speichern löschen.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

apache079

apache079

Sprinter-Fahrer

Beiträge: 6

  • Nachricht senden

6

Montag, 7. März 2016, 09:40

Oha, Dank Dir. Dann kann das ja nicht klappen. Ich habe aus "/vehicle/trailer_eu/trailer/trailer.pmd" nämlich "/vehicle/trailer/dump_bottom/trailer.pmd" gemacht. Das haut ja von den Stellen her garnicht hin. Also du sagst es kommt nur auf die Anzahl der Stellen an? Dann könnte ich ja machen "/vehicle/trailer_us/bottom/trailer.pmd"? Oder "grain1" oder so. Also "/vehicle/trailerXXX/XXXXXX/trailer.pmd" dann sollte das gehen? Hätte ja nicht gedacht dass das so tief verwurzelt ist. Ach ja, die Namen der mats und der Modelle hab ich nicht verändert, nur die Pfade dorthin. Und die pmds habe ich nicht mit einem Hex sondern einem normalen Editor gemacht. Da lag dann wohl der zweite Fehler.

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

7

Montag, 7. März 2016, 10:19

Es geht dabei um den Inhalt der pmd.
Der darf längenmässig nicht verändert werden.
Wie der Pfad lautet ist dabei völlig egal.
Es muss aber auch dieser Pfad so vorhanden sein,wie du ihn in der pmd, den mats und den tobj angibst. Und dort müssen dann natürlich die dds liegen.

Ich habe das doch richtig verstanden,dass du nur umschreibst.
Wenn du über Zmod gehst,müssen die neuen Pfade natürlich auch angegeben werden und passen. Auch der originpfad in den Eigenschaften der pmd.

Willst du das mit dem alten Paket nutzen,müssen die Namen von pmd,pmg und pmc verändert werden und dementsprechend in allen anderen def-Dateien auch,wenn du über den üblichen trailer_eu Pfad gehst.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Schlemil« (7. März 2016, 10:31)


Es haben sich bereits 2 registrierte Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

apache079, boxcar

apache079

Sprinter-Fahrer

Beiträge: 6

  • Nachricht senden

8

Montag, 7. März 2016, 10:35

Ja genau.....ich schreibe und benenne nur um. Und auch nur Ordner und Berücksichtigung auf die originale Ordnerstruktur von ATS.....habe also in der pmd nur den Pfad und NICHT den Namen des Materials geändert. Wenn der Pfad keine Rolle spielt und der Name des Materials nicht verändert wurde.....gehe ich recht in der Annahme dass das Problem nur sein kann die pmd ohne HexEditor verändert zu haben? Das alte Paket wird nicht weiter benutzt.....ich mache mir lediglich aus vielen kleinen Paketen und reinen skins ein größeres Paket....alles der Übersicht halber...deswegen auch das Umbenennen der Ordner.

Schlemil

Gigaline-Fahrer

Beiträge: 717

Danksagungen: 2174

  • Nachricht senden

9

Montag, 7. März 2016, 10:52

Ja,dann liegt es an der pfadlänge in der pmd. Und der muss mit nem Hexeditor bearbeitet werden.
Das game vergleicht pmg und pmd um Pfade zu rekonstruieren.
In der pmg ist die pmdgrösse verschlüsselt gespeichert. Die pmg lässt sich nicht verändern.
Hast du jetzt die Pfadlänge in der pmd verändert und somit die pmd grösse,passt das nicht zur pmg und das game liest wirrwar.
Ein Hexeditor weist beim speichern drauf hin,wenn die pmd grösse verändert wird. Das ist dann schon ein Alarmsignal.
Köntest in der log nachsehen bei rotem Trailer.
Da hast mit Sicherheit nen abgehackten Pfad drin stehen zu benötigten mat Dateien.

Muss mich verbessern. Mein editor heißt HxD.

Edit:
Hättest eventuell ein neues Thema erstellen sollen.
Da du nur umschreibst,passt es nicht zu Zmod Export.
Deswegen die Frage,ob du mit Zmod machst.
gruss,Schlemil
DAF XF-10x4_2 Powerliner-1020 mit KVN Trailer

wo ich gerade noch gefahren bin,kuschelt jetzt ein Hase ganz lieb mit der schwarzgrauen Teerdecke

Wenn ich auf der linken Spur Lichtgeschwindigkeit erreiche oder überschreite,was passiert dann mit meiner Lichthupe? Blende ich mich dann selbst im Rückspiegel?...

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Schlemil« (7. März 2016, 11:37)


apache079

Sprinter-Fahrer

Beiträge: 6

  • Nachricht senden

10

Montag, 7. März 2016, 11:38

Und ich dachte ich müsste im ZMod etwas ändern, deshalb hier. Ich probier das besprochene dann aus. Ansonsten mach ich einen neuen Fred auf. Bis hier schonmal Danke :thumbsup:

Social Bookmarks

Counter:

Hits heute: 102 827 | Hits gestern: 98 342 | Hits Tagesrekord: 197 176 | Hits gesamt: 66 056 239 | Hits pro Tag: 23 704,15

Klicks heute: 128 453 | Klicks gestern: 124 456 | Klicks Tagesrekord: 756 082 | Klicks gesamt: 476 440 684 | Klicks pro Tag: 170 969,77 | Gezählt seit: 3. Mai 2011, 07:40

Ungelesene Beiträge Unbeantwortete Themen Themen der letzten 24 Stunden

Euro Truck Simulator,Euro Truck Simulator 2,German Truck Simulator,Forum,Community,Downloads,Support,Euro Trucksimulator,Euro Trucksimulator 2,German Trucksimulator,Trucks,18 Wheels of Steel,Haulin,Convoy,Pttm,Long Haul,Trucksimulator,Trucksimulation,Truck Simulator,Simulation,ATS,Trucksim,Extreme Trucker 2,ETS,ETS2,GTS,UKTS,ET,ET2,18WoS,Tutorial,Tutorials,Tipp,Zmodeler,z3d,Modding,SCS,simulation,support, Zmod,z3d,Sk,Skins,Map,Maps,Mod,Mods,Trucksims,STD,Scania Truck Driving Simulator,Scania,ETS2Mods, Euro Trucksimulator2 Mods